AIX Cheatsheet
#
AIX (Advanced Interactive eXecutive) is IBM’s proprietary Unix operating system, known for its robustness and enterprise-level features. It is commonly used on IBM’s Power Systems hardware. Below is a comprehensive cheatsheet to help you get started with AIX, covering various commands and their descriptions.
Command | Description |
---|
uname -a | Display all system information |
prtconf | Display system configuration |
lsattr -El sys0 | Display system attributes |
lsdev -C | List all devices |
errpt | Display system error report |
topas | Display real-time system statistics |
ps -ef | List all running processes |
lslpp -L | List installed software packages |
installp -a -d <device> <package> | Install a software package |
smitty | System Management Interface Tool |
User and Group Management
#
Command | Description |
---|
mkuser <username> | Add a new user |
rmuser <username> | Delete a user |
usermod -G <group> <username> | Add a user to a group |
mkgroup <group> | Create a new group |
rmgroup <group> | Delete a group |
passwd <username> | Change a user’s password |
Network Management
#
Command | Description |
---|
ifconfig -a | Display all network interfaces |
ping <hostname/IP> | Send ICMP ECHO_REQUEST to network hosts |
netstat -rn | Display the routing table |
route add <destination> <gateway> | Add a static route |
lsattr -El inet0 | Display network attributes |
smitty tcpip | Configure TCP/IP network settings |
Disk Management
#
Command | Description |
---|
df -k | Display disk usage in kilobytes |
du -sk <directory> | Show disk usage of a directory |
lsvg | List volume groups |
lslv | List logical volumes |
mount | Display all mounted filesystems |
mount <device> <directory> | Mount a filesystem |
umount <directory> | Unmount a filesystem |
crfs -v jfs2 -g <vg> -a size=<size> -m <mount_point> -A yes | Create a new filesystem |
System Services and Daemons
#
Command | Description |
---|
startsrc -s <service> | Start a service |
stopsrc -s <service> | Stop a service |
refresh -s <service> | Refresh a service |
lssrc -a | List all services |
lssrc -s <service> | Display the status of a service |
File Operations
#
Command | Description |
---|
cp <source> <destination> | Copy files or directories |
mv <source> <destination> | Move or rename files or directories |
rm <file> | Delete a file |
rm -r <directory> | Delete a directory and its contents |
chmod <permissions> <file> | Change file permissions |
chown <owner>:<group> <file> | Change file owner and group |
ln -s <target> <link> | Create a symbolic link |